Civilization и Total War

 

Имя
Пароль  
Забыли пароль?
Регистрация


CIVru.com / Civilization 4 - Техническая Поддержка / Установка патчей, аддонов и прочая
Версия для печати . Вверх
Автор Сообщение
kicks
Участник


Репутация: 3111540(???)

# Дата: 1 Фев 2010 19:00:16 Поправил: kicks Цитата

Внимательно изучите ниженаписанное и после четко задавайте вопросы.

Аддоны:

1. Для установки аддонов Warlords и BtS необходима установленная игра Civilization IV.

2. Для установки аддонов Warlords и Эпоха Огня (BtS) от фирмы 1С, небоходима установленная игра Civilization IV от 1С.

3. Для установки аддона BtS/Эпоха огня - аддон Warlords устанавливать не обязательно.

ВАЖНО!

Как установить аддон Эпоха Огня от 1С на Civilization 4 не от 1С

Как установить последние патчи и оригинальный Beyond the Sword на локализацию от 1С

Патчи:

1. На официальную английскую версию ставится: официальный патч 3.17 или урезанный патч 3.17 или официальный патч 3.19 или урезанный патч 3.19.

2. На пиратскую английскую версию ставится: урезанный патч 3.17 или 3.19 или пробовать через правку реестра воткнуть официальный.

3. На официальную русскую версию от 1С ставится: официальный патч 3.17 или адаптированный патч 3.17 для 1С или официальный патч 3.19 или адаптированный патч 3.19 для 1С.

4. На пиратскую русскую версию от 1С ставится: адаптированный патч 3.17 для 1С и ПОТОМ адаптированный патч 3.19 для 1С.

ВАЖНО! Для п1, п2 и п3 Если ставится патч 3.19 то 3.17 ставить не надо.

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 3 Фев 2010 13:25:33 Цитата

Как я устанавливала Цивилизацию 4 (не от 1С) и Эпоху огня

1. Устанавливаем Civilization 4 классическую.
2. Устанавливаем патч 1.74 (брать здесь).
3. Если патч 1.74 начинает ругаться, что "игра не установлена" и т.п., с помощью программки Civ4RegPatch.exe (берем здесь), указываем папку с установленной игрой и снова запускаем программу установки патча.

4. Распаковываем этот архив в папку ..\Assets\XML\Text\
5. Запускаем программу установки и устанавливаем Эпоху огня.
6. Устанавливаем патч 3.19 на Эпоху огня - брать здесь.
7. Никакого диска не требуется - наслаждаемся игрой!

Супер

Спасибо kicksу!

kicks
Участник


Репутация: 3111540(???)

# Дата: 3 Фев 2010 16:05:27 Поправил: kicks Цитата

Sungirl

Есть у меня догадка, что патч 1.74 ставить не надо, т.к. Эпоха Огня его уже содержит.

Теоретически, достаточно выполнить следующее:
п.1 выполняем
п.2 пропускаем
п.3 делаем только Sungirl:с помощью программки Civ4RegPatch.exe (берем здесь), указываем папку с установленной игрой
и далее выполняем с п.4 по п.7.

Кто бы проверил ...

kicks
Участник


Репутация: 3111540(???)

# Дата: 6 Фев 2010 14:09:10 Поправил: kicks Цитата

Обновление DirectX 9c до 05.02.2010

Если стоял предыдущий - то качаем этот.

Если нужен полный пакет, берем здесь - 105 Мбт

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 23 Фев 2010 17:42:41 Цитата

Провела небольшой эксперимент.
Установила сначала классику версия 1.00. Затем подложила файл CIV4GameTextInfos_Cities.xml и установила Эпоху огня, затем установила на нее патч 3.19. Скопировала полученную папку с цивой в другое место, все снесла.

Вновь установила классику 1.00. Установила патч 1.74.. Файл art0.fpk успешно разделился на 4 части (в предыдущем случае этого не произошло). Подложила файл CIV4GameTextInfos_Cities.xml и установила Эпоху огня, затем установила на нее патч 3.19.

Было замечено следующее. Если не ставить отдельно патч 1.74, а "пропатчивать при помощи Эпохи огня с патчем 3.19", то в ассетах классики произойдет весьма немного изменений. Патч 1.74 в отдельности вносит этих изменений гораздо больше.

Правда, игра запускается и идет при любом способе установки, но в первом варианте долго не играла.

Вывод:
Если кто устанавливает Эпоху огня на классику 1.00, патч 1.74 лучше ставить отдельно, а не полагаться на то, что "Эпоха огня сама все пропатчит".

бигфуд
Участник


Репутация: 2306350(???)
# Дата: 23 Фев 2010 18:47:40 Цитата

А не проще установить Sid Meier's Civilization 4 Complete ? Там уже ведь всё пропатченго. Улыбка

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 27 Фев 2010 11:37:05 Цитата

Файл реестра для BtS.

Вроде должен помогать при проблемах при установке официальных патчей на BtS (по мотивам этой темы).

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 27 Фев 2010 11:45:24 Цитата

бигфуд:А не проще установить Sid Meier's Civilization 4 Complete ? Там уже ведь всё пропатченго
А разве Complete Edition включает патч 3.19? По-моему, этот патч вышел позже, чем Complete Edition.
Или имеется в виду Civilization IV: Полное собрание от 1С?

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 27 Фев 2010 11:54:17 Поправил: Sungirl Цитата

Относительно Civilization IV: Полное собрание от 1С.

Там обнаружилась весьма неприятная вещь.
Прочитать можно здесь. Ниже процитирую кое-что оттуда.

Ребят у 1С в этой сборке интегрирована BTS3.1.9 версии, но она у них какая-то глючная в плане текстовой части, полно мест где вместо текста просвечиваются скрипты.
В описании карт.
В описании отношений с компьютером.
и так далее.


Сегодня я еще раз установил всё и наконец сравнил тексты локализации и оригинала - в локализации 3.19 элементарно не хватает тегов (как раз тех, кот. потом маячат в виде TXT_KEY...)!


1С жжот Широкая улыбка

MadPsycho
Участник


Репутация: 2000000(???)
# Дата: 29 Мар 2010 20:35:43 Цитата

Сделал как все здесь написано, не работают парадигмы. Что делать?

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 6 Апр 2010 08:48:08 Цитата

MadPsycho, создай, пожалуйста, отдельную тему, где как можно подробнее опиши свою ситуацию. Какая версия игры, игра от 1С или нет?

MadPsycho:не работают парадигмы
В чем конкретно проявляется их "неработа"? Возможно, не открыты соответствующие технологии Подмигивание

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 6 Апр 2010 09:25:23 Цитата

Sungirl:Относительно Civilization IV: Полное собрание от 1С.
Там обнаружилась весьма неприятная вещь.


Эта весьма неприятная вещь возникает также после установки официального патча 3.19 от 1С.

Цитирую отсюда.


«Civilization IV: Эпоха огня» версии 3.19 и «Civilization IV: Полное собрание» содержат ряд технических ошибок, результатом чего является появление в игре в некоторых местах кодовых стрингов "TXT_KEY_..." вместо нормального текста. Неофициальный фикс для 1С устраняет данные ошибки и нормализует тексты


Фикс можно взять там же, в шапке темы.


1С... просто нет слов... :akm:

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 18 Июн 2010 07:19:36 Поправил: Sungirl Цитата

Неофициальный патч 3.19 (НЕ для 1С, по-моему).
Цитирую отсюда.

Кумулятивный патч 3.19, для BtS:
Для тех, у кого по тем или иным причинам не ставится официальный патч 3.19.
Это точная копия патча, только распакованная и сжатая rar'ом.
Просто распакуйте в папку BtS с заменой всех файлов.
Перед установкой настоятельно рекомендую сделать резервную копию папки BtS.


Ссылка на скачивание (91.9М)
http://civ.bursa.ru/BtS_patch_3.19.rar

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 25 Июл 2010 19:12:43 Поправил: Sungirl Цитата

Похоже, 1С-овцы все-таки внесли исправления в свой патч 3.19.
Вроде теперь должен устанавливаться без проблем и с текстом проблем быть также не должно.
Цитирую отсюда (о патче 3.19)

Скачайте его сейчас. В патч были внесены изменения. А также то, что касалось "выпавших строк" и некоторые помарки локализации.

Полный список вносимых изменений
Ссылка для закачки вроде бы та же
http://files.games.1c.ru/civ_iv_bts/files/patch/Civ4_BTS_patch_319.rar

Ой, и чудные же они товарищи Улыбка :akm:
Я посмотрела, патч 3.19 для оригинальной BtS вышел 10.06.2009, а патч 3.19 от 1С (исправленный) появился в начале июля 2010 года Смех
Наверное, гневные выступления на форумах заставили 1С-овцев все-таки почесаться и хоть немного обратить внимание на пользователей их продуктов Широкая улыбка

1С, исправляйтесь и делайте свою работу качественно :dont:

kicks
Участник


Репутация: 3111540(???)

# Дата: 25 Июл 2010 19:23:02 Цитата

Sungirl:1С, исправляйтесь и делайте свою работу качественно
Это вряд ли. Они привыкли деньги зарабатывать, а о качестве думают в последнюю очередь.

KINGHIJL
Участник


Репутация: 2000000(???)
# Дата: 21 Сен 2010 12:29:47 Цитата

Как установить Лидеров?

Sungirl
Участник



Репутация: 2480520(???)
# Дата: 21 Сен 2010 16:50:33 Цитата

KINGHIJL, пожалуйста создай отдельную тему, где как можно подробнее опиши свою проблему.

мистер ХХХ
Участник


Репутация: 1779410(???)

# Дата: 16 Фев 2013 16:39:12 Цитата

Как установить Лидеров? к какой циве

anthropomorphous
Участник


Репутация: 2136280(???)
# Дата: 24 Сен 2013 20:23:04 Поправил: anthropomorphous Цитата

Ох, разжиться бы патчем BTS 3.19. Гуглил по всем форумам, но везде ссылки уже истекшие. Есть рабочая версия 3.17, но для мода Realism Invictus нужен 3.19 Замешательство
Может завалялся у кого-нибудь (англ. версия)?

UPDATE
А впрочем поспешил. Вот ссылка рабочая, может кому пригодится: Ссылка

Версия для печати . Вверх

ОСТАВЛЯТЬ СООБЩЕНИЯ МОГУТ ТОЛЬКО ЗАРЕГИСТРИРОВАННЫЕ ПОЛЬЗОВАТЕЛИ!

Администрация форума: editors@civru.com
Rambler's Top100
XML [?]